PPP dialout on a Cisco 2501

PPP dialout on a Cisco 2501

A few things to note about this configuration:

This method uses a hard coded username and password for login. Cisco should be able to use PAP and CHAP to authenticate themselves as well but I haven't gotten that far yet.

Also, This is a DDR config. This means that the connection won't be active immediately and cannot be forced open. It will only activate when "interesting" traffic is sent to a destination which would be out the Async interface. Which traffic classifies as interesting is defined in the "dialer-list" command. Since the PPP connection is unnumbered (I haven't found a way to number a connection), you must place a static route to the gateway on the other end in your routing table. (refference "ip route 206.165.11.26 255.255.255.255 Async1" below.)

The connection can then be initiated by issuing a ping from the router's exec or (the more prefered way) having a process on a system off the local ethernet send traffic of some sort, be it ICMP to the PPP gateway or what, out the interface at intervals.

Sample config

!
! Last configuration change at 03:12:37 UTC Tue Dec 24 1996
! NVRAM config last updated at 03:12:54 UTC Tue Dec 24 1996
!
version 11.2
no service finger
!
hostname ppp
!
enable password cisco
!
ip name-server 206.165.5.10
chat-script usrinit "" "atz" "OK"
chat-script dial ABORT ERROR ABORT BUSY ABORT "NO CONNECT" "" "ATDT 555-5555" TIMEOUT 30 "CONNECT"
chat-script login ABORT "invalid" TIMEOUT 15 ogin: pppuser word: simple
!
interface Ethernet0
 ip address 206.165.137.33 255.255.255.224
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip mroute-cache
 no ip route-cache
 shutdown
!
interface Serial1
 no ip address
 no ip mroute-cache
 no ip route-cache
 shutdown
!
interface Async1
 ip unnumbered Ethernet0
 no ip mroute-cache
 encapsulation ppp
 async dynamic routing
 async mode dedicated
 peer default ip address 206.165.11.26
 dialer in-band
 dialer wait-for-carrier-time 120
 dialer map ip 206.165.11.26 name pppuser modem-script dial system-script login broadcast 555-5555
 dialer-group 1
 no cdp enable
 pulse-time 3
!
no ip classless
ip route 0.0.0.0 0.0.0.0 206.165.11.26
ip route 206.165.11.26 255.255.255.255 Async1
!
logging 206.165.137.34
!
dialer-list 1 protocol ip permit
banner motd 
                    Authorized Persons Only
                      All others, get lost

!
line con 0
 exec-timeout 30 0
line aux 0
 script reset usrinit
 modem InOut
 transport input all
 rxspeed 38400
 txspeed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 30 0
 password cisco
 login
!
ntp clock-period 17179867
ntp server 192.43.244.18
ntp server 128.8.10.6
end


web@typo.org